Announcement

Collapse
No announcement yet.

Pistons question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pistons question

    So:
    when a cannon fires, the force pushes it back right. So, I have a connon on a hover tank. The main body of the cannon is fixed to the top of the ‘tank’ by a bolt, that can be rotated up and down (for aiming) and there’s a second piece, the barrel, that is fixed to the body of the cannon via a slider piston, so when I fire, it triggers a key frame that briefly pushes the barrel backwards into the cannon body, and then back out again.
    the issue is, it’s being effected by gravity, even though it’s ‘effected by gravity’ is turned off. If it faces forward, it all works beautifully, but the further up it’s pointed, the less the logic works ie, it stops moving in and out, and it also wobbles around slightly with sudden movements .....I also have issues with the bolt, it too, drifts up and down slightly with inertia, meaning it doesn’t keep its angle after a while....what am I doing wrong?

    things I’ve thought of to correct;

    piston strength is set to 0, tightness is at about 60%, and more and it won’t move, any less and it slides back and forth with inertia

    its not a parent, it’s it’s own object fixed to another object, that in turn is fixed to a parent (the tank) via a bolt, does that effect things ? (I seemed to have skipped the ‘adding objects to parents group’ it doesn’t make sense in my mind lol

    is the key frame a silly idea to make it move? I tried powering a piston in and out but got the same drifting issues

    The bolts tightness is 99%

    Thoughts ?

    EDIT: I’ve been trying this ‘grouping’ thingie and if I try and group the cannon, it disconnects the bolt and piston from the main tank body....I’ve also tried adding a new piece to the tank and grouping it to the tank, and not only will it NOT stay with the tank when moving (even though in edit, if you grab the tank it follows the tank in it’s set place) but it also removes the bolts and slider piston from the tanks body...whaaaaaa?

    and thanks
    Last edited by Shade_seeker; 25th October 2019, 06:41 PM.

  • #2
    I’ve done some troubleshooting for similar issues but it’s hard without seeing it firsthand. My first guess is that you might need to make the barrel non-moveable (in the tweak menu for that sculpt or group). If that doesn’t work I’d be happy to take a look, of you want to add me a as a collaborator temporarily.

    My power might get get shut off this weekend though so I might not be available for a few days

    Comment


    • #3
      Originally posted by Pookachoo View Post
      I’ve done some troubleshooting for similar issues but it’s hard without seeing it firsthand. My first guess is that you might need to make the barrel non-moveable (in the tweak menu for that sculpt or group). If that doesn’t work I’d be happy to take a look, of you want to add me a as a collaborator temporarily.

      My power might get get shut off this weekend though so I might not be available for a few days
      darm it, sorry Pookachoo, I only just noticed your reply!

      I tried changing it to non movable, and it had some kinda epileptic fit! When crazy town on me lol. I don’t get this grouping thing, it seems to totally screw up with any separate sculptures added to the group (selecting the tank first, and THEN The new object to add.....perhaps that’s the issue? I seem to have it in my head you select the parent first then the object you want to add to it?

      it’s all not a big issue, I’m just making crap to learn/relearn, I’m more of a ‘fiddle for hours’ type of guy than a ‘follow a tutorial’ or ‘find someone else’s work and copy it’ kinda guy.........it seems to sink in that way

      Appreciate the reply and offer to help, might take you up on that once I get to grips with what I’m doing ....atm it’s just a total mess and a fun play park for me

      Comment


      • #4
        Yeah, grouping that way will cause problems. If you select an existing group and another object and group those, you’ve made a new group that contains the original. What you need to do is grab and hold the object, then scope into the group with L1+X and then let go of that object and it gets dropped into the group

        Comment


        • #5
          Originally posted by Pookachoo View Post
          Yeah, grouping that way will cause problems. If you select an existing group and another object and group those, you’ve made a new group that contains the original. What you need to do is grab and hold the object, then scope into the group with L1+X and then let go of that object and it gets dropped into the group
          Ooo, thank you! I know that’s ludicrously simple, but I haven’t got to grips with that yet....will try it later when the mrs is asleep hahha

          Comment

          Working...
          X